Jump to content

Follow us on...
Home
Sign Up Now FAQ
Signup Now
In order to make a post or to start a new thread and or to interact with other
members of this board, you wil need to create an account first.
Photo
- - - - -

Ick outbreak overnight! Help pls


  • Please log in to reply
14 replies to this topic

#1 Plecoholic

Plecoholic

    Advanced Member

  • Members
  • PipPipPip
  • 71 posts
  • LocationKeswick

Posted 10 February 2014 - 02:17 PM

I was turning my cichlid fry tank lights on which is a 10 gallon and saw my BN Green Dragon covered in white spots. Parameters are Ammonia 0 Nitrite 0 Nitrate 5-10 Temp is 26 on the way up to 29-30. I added an air stone and API Super ick cure. Does anyone have any exp. with this on Plecos ??? Is there anything else I can do?? All opinions and help appreciated.......


Thanks
Ted.K.
YRPDAC Group
http://www.youtube.c...ser/YRPDACGroup

#2 Dis

Dis

    Pleco Fry

  • Members
  • 401 posts

Posted 10 February 2014 - 05:21 PM

I had it I. My tank for a few days, lots of water changes and high temp. Good luck with the fry

#3 Plecoholic

Plecoholic

    Advanced Member

  • Members
  • PipPipPip
  • 71 posts
  • LocationKeswick

Posted 10 February 2014 - 06:43 PM

So I come to check how it's going with green dragon. Still spotted.

And I see my Sf BN Pleco fanning a fresh batch of eggs.

The bad thing is the tank is medicated for the ich.

Attached Thumbnails

  • image.jpg
  • image.jpg



Thanks
Ted.K.
YRPDAC Group
http://www.youtube.c...ser/YRPDACGroup

#4 jimmy chonga

jimmy chonga

    Juvie Pleco

  • Members
  • 579 posts
  • LocationToronto

Posted 10 February 2014 - 08:18 PM

yea there is alot posted on here about treating ich in regards to plecos. I had an outbreak a while back and all of my guys made it through. raise the temps and use a good ich medication. dont bother with organic stuff



#5 Plecoholic

Plecoholic

    Advanced Member

  • Members
  • PipPipPip
  • 71 posts
  • LocationKeswick

Posted 10 February 2014 - 08:31 PM

Thanks for that reply. Has anyone ever had eggs while being medicated? I have feeling I should write them off ? Just have to wait and see.


Thanks
Ted.K.
YRPDAC Group
http://www.youtube.c...ser/YRPDACGroup

#6 CanadaPleco

CanadaPleco

    Admin/Owner

  • Administrators
  • 3039 posts
  • LocationMinden, ON

Posted 10 February 2014 - 08:40 PM

I don't ever medicate anymore for ich....  high temps and lots of salt, cures it fine every time.


Rich

BreakthruDesigns.ca - Chainsaw Carvings by Rich
CanadaPleco.com - Our Plecos Suck Harder - Canadian Forums for Pleco Enthusiasts

emailsig.png

 


#7 Dutch

Dutch

    Juvie Pleco

  • Members
  • 494 posts
  • LocationBradford

Posted 10 February 2014 - 11:50 PM

I agree with Rich, in the store I use cupramine aswell as the high temps and salt to try and cure it even faster to get them back up for sale quicker but high temps and salt will do it



#8 Plecoholic

Plecoholic

    Advanced Member

  • Members
  • PipPipPip
  • 71 posts
  • LocationKeswick

Posted 11 February 2014 - 12:26 AM

No change yet. But not looking any worse. Temps are finally up to 86 and salt is in along with the API ich cure only because I had it on hand.

Father pleco ich and all is a champ and still fanning. I figure I'll roll the dice on the eggs. Might be my first hatch with Pleco's. Fingers crossed.


Thanks
Ted.K.
YRPDAC Group
http://www.youtube.c...ser/YRPDACGroup

#9 Plecoholic

Plecoholic

    Advanced Member

  • Members
  • PipPipPip
  • 71 posts
  • LocationKeswick

Posted 11 February 2014 - 12:31 AM

I agree with Rich, in the store I use cupramine aswell as the high temps and salt to try and cure it even faster to get them back up for sale quicker but high temps and salt will do it


Rich also has that magic well water straight from the earth I'm sur ther something special in there.
Lol


Thanks
Ted.K.
YRPDAC Group
http://www.youtube.c...ser/YRPDACGroup

#10 CanadaPleco

CanadaPleco

    Admin/Owner

  • Administrators
  • 3039 posts
  • LocationMinden, ON

Posted 11 February 2014 - 01:18 AM

I don't have any magic water at all, I sure wish it was softer, its liquid rock.  High temps and lots of salt is all I use.


Rich

BreakthruDesigns.ca - Chainsaw Carvings by Rich
CanadaPleco.com - Our Plecos Suck Harder - Canadian Forums for Pleco Enthusiasts

emailsig.png

 


#11 matti2uude

matti2uude

    Juvie Pleco

  • Members
  • 532 posts
  • LocationToronto

Posted 11 February 2014 - 01:22 AM

I followed this when I had it and it worked for me.
http://plecoplanet.com/?page_id=436

#12 Plecoholic

Plecoholic

    Advanced Member

  • Members
  • PipPipPip
  • 71 posts
  • LocationKeswick

Posted 11 February 2014 - 02:02 AM

I followed this when I had it and it worked for me. http://plecoplanet.com/?page_id=436


I'm pretty much doing the same only I started with the API so I'll see where that takes me.

My biggest problem was getting over the shock of having ich in the first place then of course panic then panic again when I seen the eggs. NUTS!!!!


Thanks
Ted.K.
YRPDAC Group
http://www.youtube.c...ser/YRPDACGroup

#13 matti2uude

matti2uude

    Juvie Pleco

  • Members
  • 532 posts
  • LocationToronto

Posted 11 February 2014 - 05:16 AM

I think the salt and the heat does the most anyway.
If you lose the eggs it's unfortunate, but there will be more for sure.

#14 Plecoholic

Plecoholic

    Advanced Member

  • Members
  • PipPipPip
  • 71 posts
  • LocationKeswick

Posted 13 February 2014 - 10:41 PM

A little update. Done adding salt. All spots seem to be gone. And I moved 6 cichlid fry to another medicated tank. Did a 25% water change and brought the salt level back up slowly. I did see one orange egg was laying in the sand. (Reminded me of watch Nemo with my son). Maybe a halucination but I could swear it had a tiny, I mean real tiny tail.
How would you even begin to put that back with papa pleco? He's still fanning away!
Again all, thank you for the advice...


Thanks
Ted.K.
YRPDAC Group
http://www.youtube.c...ser/YRPDACGroup

#15 Plecoholic

Plecoholic

    Advanced Member

  • Members
  • PipPipPip
  • 71 posts
  • LocationKeswick

Posted 25 February 2014 - 12:35 AM

Final update: All is well all fish doing fine....most of the eggs hatched but I'm pretty sure we're eaten by others in the tank.
Thx everyone for all your help.


Thanks
Ted.K.
YRPDAC Group
http://www.youtube.c...ser/YRPDACGroup




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users